A po co mi ten VPLS? Nie lepsze są VLANy?

baza wiedzy Network Expert

A po co mi ten VPLS? Nie lepsze są VLANy?

Mali i średni operatorzy w większości budują swoje sieci w oparciu o VLANy. Gdy klientów mamy stosunkowo niewielu – jest to rzeczywiście tanie i proste rozwiązanie. Problem zaczyna się, gdy ilość urządzeń w sieci rośnie, a operacja pt. „rozciągnięcie VLANa” przyprawia o zawrót głowy.

Z pomocą przychodzi VPLS (Virtual Private LAN Services), który jest VPNem warstwy L2 działającym w oparciu o technologię MPLS w rdzeniu sieci. W przeciwieństwie do Xconnecta, VPLS pozwala na budowanie połączeń typu multipoint-multipoint. Routery klasy PE nawiązują między sobą sesje, tzw. VC (Virtual Circuit), gdzie każde VC o tym samym ID tworzy VFI (Virtual Forwarding Instance), co identyfikuje danego klienta. Z punktu widzenia klienta operator działa jak jeden duży switch, który łączy wszystkie jego lokalizacje w warstwie L2. Operator zyskuje ogromną skalowalność oraz brak jakichkolwiek modyfikacji w rdzeniu sieci przy dodawaniu kolejnych „końcówek”. Poniżej prosty config dla trzech routerów Cisco ASR920 połączonych w tzw. ring.

hostname R1

!

mpls label range 100 199

mpls label protocol ldp

!

l2 vfi KLIENT manual

vpn id 100

neighbor 2.2.2.2 encapsulation mpls

neighbor 3.3.3.3 encapsulation mpls

bridge-domain 100

!

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

interface GigabitEthernet0/0/1

description TO_R2

ip address 172.12.12.12 255.255.255.0

mpls ip

!

interface GigabitEthernet0/0/5

description TO_R3

ip address 172.13.13.13 255.255.255.0

mpls ip

!

interface GigabitEthernet0/0/10

description KLIENT

no ip address

negotiation auto

service instance 100 ethernet

encapsulation untagged

rewrite ingress tag push dot1q 100 symmetric

bridge-domain 100

!

!

mpls ldp router-id Loopback0 force

hostname R2

!

mpls label range 200 299

mpls label protocol ldp

!

l2 vfi KLIENT manual

vpn id 100

neighbor 1.1.1.1 encapsulation mpls

neighbor 3.3.3.3 encapsulation mpls

bridge-domain 100

!

interface Loopback0

ip address 2.2.2.2 255.255.255.255

!

interface GigabitEthernet0/0/1

description TO_R1

ip address 172.12.12.21 255.255.255.0

mpls ip

!

interface GigabitEthernet0/0/3

description TO_R3

ip address 172.23.23.23 255.255.255.0

mpls ip

!

interface GigabitEthernet0/0/10

description KLIENT

no ip address

negotiation auto

service instance 100 ethernet

encapsulation untagged

bridge-domain 100

!

!

mpls ldp router-id Loopback0 force

hostname R3

!

mpls label range 300 399

mpls label protocol ldp

!

l2 vfi KLIENT manual

vpn id 100

neighbor 1.1.1.1 encapsulation mpls

neighbor 2.2.2.2 encapsulation mpls

bridge-domain 100

!

interface Loopback0

ip address 3.3.3.3 255.255.255.255

!

interface GigabitEthernet0/0/3

description TO_R2

ip address 172.23.23.32 255.255.255.0

mpls ip

!

interface GigabitEthernet0/0/5

description TO_R1

ip address 172.13.13.31 255.255.255.0

mpls ip

!

interface GigabitEthernet0/0/10

description KLIENT

no ip address

negotiation auto

service instance 100 ethernet

encapsulation untagged

rewrite ingress tag push dot1q 100 symmetric

l2protocol peer

bridge-domain 100

!

!

mpls ldp router-id Loopback0 force

Od samego początku naszej działalności stawialiśmy na profesjonalne podejście do naszych Klientów

Network w liczbach

0
lat na rynku
0
realizacji
0
Klientów

Od samego początku naszej działalności stawialiśmy na profesjonalne podejście do naszych Klientów

Network w liczbach

0
lat na rynku
0
realizacji
0
Klientów
2019-01-07T14:50:04+00:00