Switch Stack i EtherChannel

baza wiedzy Network Expert

Stakowanie switchy

Stakowanie – łączenie switchy w jedno urządzenie. Switche stackowalne to takie, które można używać jako switche wolno stojące, jak również można je łączyć ze sobą w jedno urządzenie. Switche będą widziane jako logiczna jedność np. do zarządzania wszystkimi będzie potrzebny tylko jeden adres IP, ale ich możliwości będą w dużej mierze sumą pojedynczych urządzeń. Switche można podłączać i odłączać od stacku, nie powodując przy tym przerw w działaniu całości, każdy switch dostaje swój numer. W małej firmie, można zbudować całą sieć wokół jednego stacku, co znacznie ułatwi jej administrowanie. Wszelkie zmiany dla całego stacku wprowadza się z jednej linii komend. Stack w sieci używającej spanning-tree jest widoczny jako jeden switch. Awaria jednego z urządzeń nie ma wpływu na pracę pozostałych. Łączenie urządzeń w ten sposób znacznie zwiększa redundancję i ich możliwości dostępu. W stacku do każdego urządzenia dane mogą być przesyłane dwiema drogami, każdy switch jest połączony specjalnymi kablami ze swoimi sąsiadami, dzięki temu powstaje dwustronna droga tak zwany „ring”. Switche muszą być wyposażone w specjalne moduły, by mogły brać udział w stackowaniu. Na stackowaniu zyskują również łącza uplink, możemy mieć tutaj redundancję połączeń upstream, dzięki czemu utrata jednego uplinka, nie zakłóci podłączenia całości.

Na poniższym rysunku przedstawione zostały dwa warianty podłączenia switchy z warstwy dostępowej do warstwy dystrybucyjnej. Po lewej stronie switche nie są połączone w stack, można zauważyć, że awaria, któregokolwiek z łączy uplink (kolor czerwony) spowoduje brak łączności pomiędzy switchami. Po prawej stronie switche są w stacku (połączenie kolorem zielonym), awaria łącza uplink na którymkolwiek urządzeniu nie ma wpływu na poprawne działanie:

Stakowanie switchy

W stacku jeden ze switchy jest wybierany jako switch master, będzie on zarządzał wszystkimi urządzeniami. W razie jego awarii automatycznie kolejny switch przejmuje jego rolę. W stacku jest jeden plik konfiguracyjny, przekazywany do każdego urządzenia, dzięki temu wszyscy mają ten sam widok na całą sieć, informacje na temat routingu, czy adres MAC. Jedno miejsce konfiguracji to również ułatwienie w eksploatacji – dbać musimy o backup de facto jednego urządzenia zamiast kilku.

Wybór stack mastera:

  • priorytet użytkownika – administrator wybiera switch, który ma pełnić funkcję mastera
  • priorytet sprzętowy i programowy – ten switch, który jest najbardziej zaawansowany technicznie zostanie wybrany
  • domyślna konfiguracja – jeżeli któryś ze switchy jest już skonfigurowany ma on przewagę nad tymi, które nie są
    czas pracy – switch, który pracuje najdłużej
  • adres MAC – ten switch, który ma najniższy adres MAC

Do sprawdzenia numeru switcha w stacku służy komenda: show switch. Nowe switche mają ustalony numer 1. Do ręcznej zmiany numeru używa się: switch 4 renumber 2. Jeżeli ten numer jest już zajęty switch wybierze najniższy wolny numer.

Cisco opracowało kilka opcji statkowania, w zależności w jakich modelach switchy będzie stosowany. W switchach serii: 2960-S, 2960-X i 2960-XR zastosowano: FlexStack i FlexStack-Plus. W switchach serii: 3750, 3750-E, 3560-X, 3750-X i 3850 zastosowano: StackWise i StackWise Plus.

Cisco stack power

Jest to nowe rozwiązanie polegające na lepszym podziale mocy w stacku, pozwalające na jednoczesne kontrolowanie przydziału i oszczędzanie. StackPower przydziela nadwyżkę mocy temu switchowi, który w tym momencie został obciążony np. dodatkowymi urządzeniami PoE. Switche wymieniają się informacjami, o tym który z nich potrzebuje ile mocy. Opcja show stack-power pozwala na sprawdzenie statusu i zapotrzebowań mocy.

EtherChannel – stackowanie portów

W poprzedniej części pisaliśmy o łączeniu całych urządzeń w jedno logiczne, EtherChannel działa podobnie, tylko że w tym przypadku łączone są porty. Etherchannel jest nazwą charakterystyczną dla Cisco, nazwą standardową jest LAG lub Link Aggregation. LAG Pozwala na utworzenie bardzo wydajnych i redundantnych łącz do połączenia pomiędzy urządzeniami sieciowymi. W tym przypadku, również wszystkie porty połączone, będą reprezentowane przez jeden adres IP i MAC. Można łączyć porty Fast, Gbit i 10Gbit Ethernetowe, uzyskując przy tym przepustowość do 80Gbit/s (większość switchy może zrobić Ethernchannel z max 8 interfejsów). W momencie awarii jednego z portów cały ruch zostaje podzielony na resztę działających portów. Tak jak w przypadku statkowania switchy spanning-tree widzi połączone porty jako jedność, można to połączenie zastosować jako trunk. W wolnostojących switchach wszystkie porty należące do jednego EtherChannelu muszą znajdować się na jednym switchu, w przypadku stacku, mogą być rozbite po różnych urządzeniach. Do zarządzania portami wykorzystywane są dwa protokoły: Port Aggregation Protocol lub Link Aggregation Control Protocol. Pierwszy z nich jest własnością Cisco i działa tylko na switchach Cisco, nie obsługuje łącznia portów w stacku. Drugi pozwala na łączenie portów w stacku i wymienia informacje na temat stanu w jakim znajdują się porty. LACP jest preferowanym rozwiązaniem, Cisco wycofuje ze wsparcia PAgP. Można skonfigurować do 16 portów w kanale, 8 w stanie aktywnym i 8 w standby. Gdyby któryś z aktywnych uległ awarii od razu zostaje zastąpiony zapasowym.

EtherChannel stany dla połączeń LACP:

  • aktywny – jest to stan, w którym port jest aktywny i negocjuje z innymi portami za pomocą pakietów LACP
  • pasywny – stan, w którym interfejs jest w stanie pasywnym, odpowiada na otrzymane pakiety LACP ale sam nie rozpoczyna konwersacji
  • on – jest to stan w którym zawsze jest włączona opcja etherchannelu na interfejsie

Przykład skonfigurowania 2 portów na tym samym switchu:

Przykładowa konfiguracja cross-stack EtherChannel bez LACP:

porty typu trunk:

Switch(config)#interface range gigabitethernet 1/0/1 – 2
Switch(config-if-range)#channel-group 1 mode on
Switch(config-if-range)#switchport
Switch(config-if-range)#switchport trunk encapsulation dot1q
Switch(config-if-range)#switchport mode trunk

porty typu access:

Switch(config)#interface range gigabitethernet 2/0/1 -2
Switch(config-if-range)#channel-group 2 mode on
Switch(config-if-range)#switchport mode access
Switch(config-if-range)# switchport access vlan 10

Konfiguracja Cross-Stack EtherChannel z LACP:

stan aktywny:

Switch(config)#interface range gigabitethernet 1/0/1 – 2
Switch(config-if-range)#channel-group 1 mode active
Switch(config-if-range)#switchport trunk encapsulation dot1q
Switch(config-if-range)#switchport mode trunk

stan pasywny:

Switch(config)#interface range gigabitethernet 1/0/1 – 2
Switch(config-if-range)#channel-group 1 mode passive
Switch(config-if-range)#switchport trunk encapsulation dot1q
Switch(config-if-range)#switchport mode trunk

Do sprawdzenia ustwien: show etherchannel 1 detail, show etherchannel summary

Przykładowe połączenie Etherchannel:

Od samego początku naszej działalności stawialiśmy na profesjonalne podejście do naszych Klientów

Network w liczbach

0
lat na rynku
0
realizacji
0
Klientów

Od samego początku naszej działalności stawialiśmy na profesjonalne podejście do naszych Klientów

Network w liczbach

0
lat na rynku
0
realizacji
0
Klientów
2019-01-17T16:00:57+00:00