Usprawnianie VPLS

baza wiedzy Network Expert

W poprzednim wpisie pokazaliśmy jak w dość prosty sposób skonfigurować router do obsługi sieci VPLS/MPLS. W tamtym przypadku sąsiadów (czyli inne routery w tej samej VPLS domenie), dodawaliśmy w sposób statyczny poprzez odpowiednie wpisy w sekcji l2 vfi. Przy 10 routerach, to już 45 wpisów! Proces ten możemy zautomatyzować dzięki protokołowi MP-BGP, który wzbogaca update o odpowiednie informacje dot. danego VFI. Dzięki takiemu rozwiązaniu przy dodawaniu lub usuwaniu routera PE sesje pseudowire są automatycznie podnoszone lub czyszczone. Jeśli dodatkowo zdecydujemy się na wdrożenie rozwiązania Route Reflector, to dodanie kolejnego klienta będzie wręcz przyjemnością. Poniżej config (bez RR).

hostname R1

!

mpls label range 100 199

mpls label protocol ldp

!

l2 vfi KLIENT autodiscovery

vpn id 100

bridge-domain 100

!

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

interface GigabitEthernet0/0/1

description TO_R2

ip address 172.12.12.12 255.255.255.0

mpls ip

!

interface GigabitEthernet0/0/5

description TO_R3

ip address 172.13.13.13 255.255.255.0

mpls ip

!

interface GigabitEthernet0/0/10

description KLIENT

no ip address

negotiation auto

service instance 100 ethernet

encapsulation untagged

rewrite ingress tag push dot1q 100 symmetric

bridge-domain 100

!

!

router bgp 555

neighbor 2.2.2.2 remote-as 555

neighbor 2.2.2.2 update-source Loopback0

neighbor 3.3.3.3 remote-as 555

neighbor 3.3.3.3 update-source Loopback0

!

address-family l2vpn vpls

neighbor 2.2.2.2 activate

neighbor 2.2.2.2 send-community extended

neighbor 3.3.3.3 activate

neighbor 3.3.3.3 send-community extended

exit-address-family

!

mpls ldp router-id Loopback0 force

hostname R2

!

mpls label range 200 299

mpls label protocol ldp

!

l2 vfi KLIENT autodiscovery

vpn id 100

bridge-domain 100

!

interface Loopback0

ip address 2.2.2.2 255.255.255.255

!

interface GigabitEthernet0/0/1

description TO_R1

ip address 172.12.12.21 255.255.255.0

mpls ip

!

interface GigabitEthernet0/0/3

description TO_R3

ip address 172.23.23.23 255.255.255.0

mpls ip

!

interface GigabitEthernet0/0/10

description KLIENT

no ip address

negotiation auto

service instance 100 ethernet

encapsulation untagged

bridge-domain 100

!

!

router bgp 555

neighbor 1.1.1.1 remote-as 555

neighbor 1.1.1.1 update-source Loopback0

neighbor 3.3.3.3 remote-as 555

neighbor 3.3.3.3 update-source Loopback0

!

address-family l2vpn vpls

neighbor 1.1.1.1 activate

neighbor 1.1.1.1 send-community extended

neighbor 3.3.3.3 activate

neighbor 3.3.3.3 send-community extended

exit-address-family

!

mpls ldp router-id Loopback0 force

hostname R3

!

mpls label range 300 399

mpls label protocol ldp

!

l2 vfi KLIENT autodiscovery

vpn id 100

bridge-domain 100

!

interface Loopback0

ip address 3.3.3.3 255.255.255.255

!

interface GigabitEthernet0/0/3

description TO_R2

ip address 172.23.23.32 255.255.255.0

mpls ip

!

interface GigabitEthernet0/0/5

description TO_R1

ip address 172.13.13.31 255.255.255.0

mpls ip

!

interface GigabitEthernet0/0/10

description KLIENT

no ip address

negotiation auto

service instance 100 ethernet

encapsulation untagged

rewrite ingress tag push dot1q 100 symmetric

l2protocol peer

bridge-domain 100

!

!

router bgp 555

neighbor 1.1.1.1 remote-as 555

neighbor 1.1.1.1 update-source Loopback0

neighbor 2.2.2.2 remote-as 555

neighbor 2.2.2.2 update-source Loopback0

!

address-family l2vpn vpls

neighbor 1.1.1.1 activate

neighbor 1.1.1.1 send-community extended

neighbor 2.2.2.2 activate

neighbor 2.2.2.2 send-community extended

exit-address-family

!

mpls ldp router-id Loopback0 force

Od samego początku naszej działalności stawialiśmy na profesjonalne podejście do naszych Klientów

Network w liczbach

0
lat na rynku
0
realizacji
0
Klientów

Od samego początku naszej działalności stawialiśmy na profesjonalne podejście do naszych Klientów

Network w liczbach

0
lat na rynku
0
realizacji
0
Klientów
2019-01-07T14:47:19+00:00